« 上一篇 下一篇 »

composer的介绍,安装和使用​

    Composer诞生于2011年,于2016年4月6日五岁生日当天发布了第一个正式版本V1.0。

    Composer 是 PHP5.3以上 的一个依赖管理工具。它允许你声明项目所依赖的代码库,它会在你的项目中为你安装他们。简单理解Composer 相当于是php的软件管家,可以管理下载php的依赖库,如:验证码类,表格导入导出,支付宝微信支付插件等。

    Composer 的安装

    安装前请务必确保已经正确安装了 PHP。打开命令行窗口并执行 php -v 查看是否正确输出版本号。


    打开命令行并依次执行下列命令安装最新版本的 Composer:

php -r "copy('https://install.phpcomposer.com/installer', 'composer-setup.php');"

php composer-setup.php

php -r "unlink('composer-setup.php');"

执行第一条命令下载下来的 composer-setup.php 脚本将简单地检测 php.ini 中的参数设置,如果某些参数未正确设置则会给出警告;然后下载最新版本的 composer.phar 文件到当前目录。

上述 3 条命令的作用依次是:

下载安装脚本 - composer-setup.php - 到当前目录。

执行安装过程。

删除安装脚本。

Windows 系统:

  1. 找到并进入 PHP 的安装目录(和你在命令行中执行的 php 指令应该是同一套 PHP)。

  2. 将 composer.phar 复制到 PHP 的安装目录下面,也就是和 php.exe 在同一级目录。

  3. 在 PHP 安装目录下新建一个 composer.bat 文件,并将下列代码保存到此文件中。

复制

@php "%~dp0composer.phar" %*

最后重新打开一个命令行窗口试一试执行 composer --version 看看是否正确输出版本号。

其他操作系统的安装方法可以参考composer中文网


composer 常用命令(基本操作):

composer require 工具包名称;

设置composer.json文件 composer install;

composer update 工具包名称;

设置composer.json文件 composer update;

composer remove 工具包名称;

设置composer.json文件 composer remove;